SDK for iOS Developer's Guide

System Requirements

  • HERE SDK supports iOS 11 or above. iOS 12 is recommended for optimal operation.
  • SDK for iOS is designed and tested for use with 64-bit iOS phones and tablets. Supported devices are:
    • iPhone 5s or newer
    • iPad Air or newer including iPad (2017) and iPad Pro
    • iPad Mini 2 or newer
  • Apps should be developed using Xcode 10 or above running on macOS 10.13.6 or above.
  • A minimum of 10MB per application should be made available for the storage of HERE SDK libraries.
  • A minimum of 32MB should be made available for the storage of map data.
  • Data connectivity (Wi-Fi or Cellular) is required to download map data.